[libvirt] [jenkins-ci PATCH 3/5] jobs: Rename {check_env} to {env}

Andrea Bolognani posted 5 patches 7 years, 5 months ago
[libvirt] [jenkins-ci PATCH 3/5] jobs: Rename {check_env} to {env}
Posted by Andrea Bolognani 7 years, 5 months ago
There's no reason to have an environment which is tied, at least
in name, to *-check-job only: having a local environment is
something that can be useful for any kind of job, so it's better
to use a neutral name.

Signed-off-by: Andrea Bolognani <abologna@redhat.com>
---
 jobs/autotools.yaml     | 2 +-
 jobs/defaults.yaml      | 2 +-
 projects/libosinfo.yaml | 2 +-
 projects/libvirt.yaml   | 2 +-
 4 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/jobs/autotools.yaml b/jobs/autotools.yaml
index 8a37d00..f6a2af0 100644
--- a/jobs/autotools.yaml
+++ b/jobs/autotools.yaml
@@ -120,7 +120,7 @@
     builders:
       - shell: |
           {global_env}
-          {check_env}
+          {env}
           cd build
           if ! $MAKE -j{smp} check
           then
diff --git a/jobs/defaults.yaml b/jobs/defaults.yaml
index e2a5b1a..86e7100 100644
--- a/jobs/defaults.yaml
+++ b/jobs/defaults.yaml
@@ -9,6 +9,6 @@
       if [ "$unamestr" = 'FreeBSD' ]; then
           MAKE='gmake'
       fi
-    check_env: |
+    env: |
     smp: 3
     spam: ymankad@redhat.com libvirt-ci@redhat.com
diff --git a/projects/libosinfo.yaml b/projects/libosinfo.yaml
index 9ab2281..311ca71 100644
--- a/projects/libosinfo.yaml
+++ b/projects/libosinfo.yaml
@@ -11,7 +11,7 @@
       - libvirt-freebsd-10
       - libvirt-freebsd-11
     title: libosinfo
-    check_env: |
+    env: |
       export OSINFO_SYSTEM_DIR=$VIRT_PREFIX/share/osinfo
     jobs:
       - autotools-build-job:
diff --git a/projects/libvirt.yaml b/projects/libvirt.yaml
index 5661066..52f8740 100644
--- a/projects/libvirt.yaml
+++ b/projects/libvirt.yaml
@@ -28,7 +28,7 @@
           parent_jobs: 'libvirt-master-build'
       - autotools-check-job:
           parent_jobs: 'libvirt-master-syntax-check'
-          check_env: |
+          env: |
             export VIR_TEST_EXPENSIVE=1
             export VIR_TEST_DEBUG=2
       - autotools-rpm-job:
-- 
2.14.3

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list
Re: [libvirt] [jenkins-ci PATCH 3/5] jobs: Rename {check_env} to {env}
Posted by Pavel Hrdina 7 years, 5 months ago
On Fri, Nov 17, 2017 at 07:26:10PM +0100, Andrea Bolognani wrote:
> There's no reason to have an environment which is tied, at least
> in name, to *-check-job only: having a local environment is
> something that can be useful for any kind of job, so it's better
> to use a neutral name.

My proposal was "job_env" and you as a reply suggested "local_env".
I would probably prefer using "local_env" over "env" since it is
local environment as you've described it in commit message :).

Pavel
--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list
Re: [libvirt] [jenkins-ci PATCH 3/5] jobs: Rename {check_env} to {env}
Posted by Andrea Bolognani 7 years, 5 months ago
On Mon, 2017-11-20 at 14:29 +0100, Pavel Hrdina wrote:
> On Fri, Nov 17, 2017 at 07:26:10PM +0100, Andrea Bolognani wrote:
> > There's no reason to have an environment which is tied, at least
> > in name, to *-check-job only: having a local environment is
> > something that can be useful for any kind of job, so it's better
> > to use a neutral name.
> 
> My proposal was "job_env" and you as a reply suggested "local_env".
> I would probably prefer using "local_env" over "env" since it is
> local environment as you've described it in commit message :).

'env' looks more natural when defining projects, but 'local_env'
mirrors 'global_env' nicely and it's way more greppable, so I've
changed it and pushed :)

-- 
Andrea Bolognani / Red Hat / Virtualization

--
libvir-list mailing list
libvir-list@redhat.com
https://www.redhat.com/mailman/listinfo/libvir-list