[PATCH 0/3] ui: Remove deprecated sdl parameters and switch to QAPI parser

Thomas Huth posted 3 patches 1 week, 1 day ago
docs/about/deprecated.rst       |  26 -------
docs/about/removed-features.rst |  27 +++++++
qapi/ui.json                    |  17 ++++-
include/sysemu/sysemu.h         |   2 -
softmmu/globals.c               |   2 -
softmmu/vl.c                    | 128 +-------------------------------
ui/sdl2.c                       |  13 ++++
qemu-options.hx                 |  56 +-------------
8 files changed, 61 insertions(+), 210 deletions(-)
[PATCH 0/3] ui: Remove deprecated sdl parameters and switch to QAPI parser
Posted by Thomas Huth 1 week, 1 day ago
The "-display sdl" option still uses a hand-crafted parser for its
parameters since some of them used underscores which is forbidden
in QAPI. Now that they've been deprecated and the deprecation period
is over, we can remove the problematic parameters and switch to use
the QAPI parser instead.

While we're at it, also remove the deprecated "-sdl" and "-curses" options.

Thomas Huth (3):
  ui: Remove deprecated parameters of the "-display sdl" option
  ui: Switch "-display sdl" to use the QAPI parser
  ui: Remove deprecated options "-sdl" and "-curses"

 docs/about/deprecated.rst       |  26 -------
 docs/about/removed-features.rst |  27 +++++++
 qapi/ui.json                    |  17 ++++-
 include/sysemu/sysemu.h         |   2 -
 softmmu/globals.c               |   2 -
 softmmu/vl.c                    | 128 +-------------------------------
 ui/sdl2.c                       |  13 ++++
 qemu-options.hx                 |  56 +-------------
 8 files changed, 61 insertions(+), 210 deletions(-)

-- 
2.27.0