[PATCH v2 00/12] hw/sd/sdcard: Accumulation of cleanups and fixes

Philippe Mathieu-Daudé posted 12 patches 2 months, 2 weeks ago
There is a newer version of this series
hw/sd/sd.c                       | 119 ++++++++++++++++---------------
tests/qtest/npcm7xx_sdhci-test.c |   7 ++
hw/sd/trace-events               |   4 +-
3 files changed, 70 insertions(+), 60 deletions(-)
[PATCH v2 00/12] hw/sd/sdcard: Accumulation of cleanups and fixes
Posted by Philippe Mathieu-Daudé 2 months, 2 weeks ago
Since v1:
- various patches merged, few more added

Various SD card cleanups and fixes accumulated over
the years. Various have been useful to help integrating
eMMC support (which will come later).

Philippe Mathieu-Daudé (12):
  tests/qtest: Disable npcm7xx_sdhci tests using hardcoded RCA
  hw/sd/sdcard: Generate random RCA value
  hw/sd/sdcard: Track last command used to help logging
  hw/sd/sdcard: Trace block offset in READ/WRITE data accesses
  hw/sd/sdcard: Do not store vendor data on block drive (CMD56)
  hw/sd/sdcard: Send WRITE_PROT bits MSB first (CMD30)
  hw/sd/sdcard: Send NUM_WR_BLOCKS bits MSB first (ACMD22)
  hw/sd/sdcard: Use READY_FOR_DATA definition instead of magic value
  hw/sd/sdcard: Assign SDCardStates enum values
  hw/sd/sdcard: Simplify sd_inactive_state handling
  hw/sd/sdcard: Restrict SWITCH_FUNCTION to sd_transfer_state (CMD6)
  hw/sd/sdcard: Add direct reference to SDProto in SDState

 hw/sd/sd.c                       | 119 ++++++++++++++++---------------
 tests/qtest/npcm7xx_sdhci-test.c |   7 ++
 hw/sd/trace-events               |   4 +-
 3 files changed, 70 insertions(+), 60 deletions(-)

-- 
2.41.0


Re: [PATCH v2 00/12] hw/sd/sdcard: Accumulation of cleanups and fixes
Posted by Cédric Le Goater 2 months, 2 weeks ago
On 6/25/24 7:53 AM, Philippe Mathieu-Daudé wrote:
> Since v1:
> - various patches merged, few more added
> 
> Various SD card cleanups and fixes accumulated over
> the years. Various have been useful to help integrating
> eMMC support (which will come later).
> 
> Philippe Mathieu-Daudé (12):
>    tests/qtest: Disable npcm7xx_sdhci tests using hardcoded RCA
>    hw/sd/sdcard: Generate random RCA value
>    hw/sd/sdcard: Track last command used to help logging
>    hw/sd/sdcard: Trace block offset in READ/WRITE data accesses
>    hw/sd/sdcard: Do not store vendor data on block drive (CMD56)
>    hw/sd/sdcard: Send WRITE_PROT bits MSB first (CMD30)
>    hw/sd/sdcard: Send NUM_WR_BLOCKS bits MSB first (ACMD22)
>    hw/sd/sdcard: Use READY_FOR_DATA definition instead of magic value
>    hw/sd/sdcard: Assign SDCardStates enum values
>    hw/sd/sdcard: Simplify sd_inactive_state handling
>    hw/sd/sdcard: Restrict SWITCH_FUNCTION to sd_transfer_state (CMD6)
>    hw/sd/sdcard: Add direct reference to SDProto in SDState
> 
>   hw/sd/sd.c                       | 119 ++++++++++++++++---------------
>   tests/qtest/npcm7xx_sdhci-test.c |   7 ++
>   hw/sd/trace-events               |   4 +-
>   3 files changed, 70 insertions(+), 60 deletions(-)
> 
Tested-by: Cédric Le Goater <clg@redhat.com>

Thanks,

C.