On 6/28/24 9:01 AM, Philippe Mathieu-Daudé wrote:
> These CMD names weren't really useful, "UNKNOWN_CMD" is simpler.
>
> Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Reviewed-by: Cédric Le Goater <clg@redhat.com>
Thanks,
C.
> ---
> hw/sd/sd.c | 5 -----
> 1 file changed, 5 deletions(-)
>
> diff --git a/hw/sd/sd.c b/hw/sd/sd.c
> index 19322c558f..0a7b422b2c 100644
> --- a/hw/sd/sd.c
> +++ b/hw/sd/sd.c
> @@ -241,12 +241,7 @@ static const char *sd_cmd_name(SDState *sd, uint8_t cmd)
> {
> static const char *cmd_abbrev[SDMMC_CMD_MAX] = {
> [18] = "READ_MULTIPLE_BLOCK",
> - [21] = "DPS_spec",
> [25] = "WRITE_MULTIPLE_BLOCK",
> - [26] = "MANUF_RSVD",
> - [40] = "DPS_spec",
> - [60] = "MANUF_RSVD", [61] = "MANUF_RSVD",
> - [62] = "MANUF_RSVD", [63] = "MANUF_RSVD",
> };
> const SDProto *sdp = sd->proto;
>